Search

yumdownloader (yumが使えないときの代用手段)

2015年10月19日

yumが使えないときの代用手段
yumが使用できるサーバからrpmをダウンロードする。

” –resolve”をつけると依存関係も含めて取得できるから便利!!!

# yumdownloader --resolve openssl
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.nus.edu.sg
 * epel: mirror01.idc.hinet.net
 * extras: ftp.yz.yamagata-u.ac.jp
 * rpmforge: mirror.oscc.org.my
 * updates: mirror.nus.edu.sg
--> Running transaction check
---> Package openssl.i686 0:1.0.1e-30.el6_6.4 will be installed
--> Processing Dependency: libz.so.1 for package: openssl-1.0.1e-30.el6_6.4.i686
--> Processing Dependency: libresolv.so.2 for package: openssl-1.0.1e-30.el6_6.4.i686
--> Processing Dependency: libkrb5.so.3(krb5_3_MIT) for package: openssl-1.0.1e-30.el6_6.4.i686
--> Processing Dependency: libkrb5.so.3 for package: openssl-1.0.1e-30.el6_6.4.i686
--> Processing Dependency: libk5crypto.so.3(k5crypto_3_MIT) for package: openssl-1.0.1e-30.el6_6.4.i686
--> Processing Dependency: libk5crypto.so.3 for package: openssl-1.0.1e-30.el6_6.4.i686
--> Processing Dependency: libgssapi_krb5.so.2 for package: openssl-1.0.1e-30.el6_6.4.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: openssl-1.0.1e-30.el6_6.4.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: openssl-1.0.1e-30.el6_6.4.i686
--> Processing Dependency: libdl.so.2 for package: openssl-1.0.1e-30.el6_6.4.i686
--> Processing Dependency: libcom_err.so.2 for package: openssl-1.0.1e-30.el6_6.4.i686
--> Processing Dependency: libc.so.6(GLIBC_2.7) for package: openssl-1.0.1e-30.el6_6.4.i686
---> Package openssl.x86_64 0:1.0.1e-30.el6_6.4 will be installed
--> Running transaction check
---> Package glibc.x86_64 0:2.12-1.107.el6 will be updated
--> Processing Dependency: glibc = 2.12-1.107.el6 for package: glibc-common-2.12-1.107.el6.x86_64
--> Processing Dependency: glibc = 2.12-1.107.el6 for package: glibc-devel-2.12-1.107.el6.x86_64
--> Processing Dependency: glibc = 2.12-1.107.el6 for package: glibc-headers-2.12-1.107.el6.x86_64
---> Package glibc.i686 0:2.12-1.149.el6 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.149.el6.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.149.el6.i686
---> Package glibc.x86_64 0:2.12-1.149.el6 will be an update
---> Package krb5-libs.x86_64 0:1.10.3-10.el6_4.3 will be updated
--> Processing Dependency: krb5-libs = 1.10.3-10.el6_4.3 for package: krb5-devel-1.10.3-10.el6_4.3.x86_64
---> Package krb5-libs.i686 0:1.10.3-33.el6 will be installed
--> Processing Dependency: libselinux.so.1 for package: krb5-libs-1.10.3-33.el6.i686
--> Processing Dependency: libkeyutils.so.1(KEYUTILS_0.3) for package: krb5-libs-1.10.3-33.el6.i686
--> Processing Dependency: libkeyutils.so.1 for package: krb5-libs-1.10.3-33.el6.i686
---> Package krb5-libs.x86_64 0:1.10.3-33.el6 will be an update
---> Package libcom_err.x86_64 0:1.41.12-14.el6_4.2 will be updated
--> Processing Dependency: libcom_err = 1.41.12-14.el6_4.2 for package: libss-1.41.12-14.el6_4.2.x86_64
--> Processing Dependency: libcom_err = 1.41.12-14.el6_4.2 for package: libcom_err-devel-1.41.12-14.el6_4.2.x86_64
--> Processing Dependency: libcom_err = 1.41.12-14.el6_4.2 for package: e2fsprogs-1.41.12-14.el6_4.2.x86_64
--> Processing Dependency: libcom_err = 1.41.12-14.el6_4.2 for package: e2fsprogs-libs-1.41.12-14.el6_4.2.x86_64
---> Package libcom_err.i686 0:1.41.12-21.el6 will be installed
---> Package libcom_err.x86_64 0:1.41.12-21.el6 will be an update
---> Package zlib.i686 0:1.2.3-29.el6 will be installed
--> Running transaction check
---> Package e2fsprogs.x86_64 0:1.41.12-14.el6_4.2 will be updated
---> Package e2fsprogs.x86_64 0:1.41.12-21.el6 will be an update
---> Package e2fsprogs-libs.x86_64 0:1.41.12-14.el6_4.2 will be updated
---> Package e2fsprogs-libs.x86_64 0:1.41.12-21.el6 will be an update
---> Package glibc-common.x86_64 0:2.12-1.107.el6 will be updated
---> Package glibc-common.x86_64 0:2.12-1.149.el6 will be an update
---> Package glibc-devel.x86_64 0:2.12-1.107.el6 will be updated
---> Package glibc-devel.x86_64 0:2.12-1.149.el6 will be an update
---> Package glibc-headers.x86_64 0:2.12-1.107.el6 will be updated
---> Package glibc-headers.x86_64 0:2.12-1.149.el6 will be an update
---> Package keyutils-libs.x86_64 0:1.4-4.el6 will be updated
--> Processing Dependency: keyutils-libs = 1.4-4.el6 for package: keyutils-libs-devel-1.4-4.el6.x86_64
---> Package keyutils-libs.i686 0:1.4-5.el6 will be installed
---> Package keyutils-libs.x86_64 0:1.4-5.el6 will be an update
---> Package krb5-devel.x86_64 0:1.10.3-10.el6_4.3 will be updated
---> Package krb5-devel.x86_64 0:1.10.3-33.el6 will be an update
---> Package libcom_err-devel.x86_64 0:1.41.12-14.el6_4.2 will be updated
---> Package libcom_err-devel.x86_64 0:1.41.12-21.el6 will be an update
---> Package libselinux.x86_64 0:2.0.94-5.3.el6_4.1 will be updated
--> Processing Dependency: libselinux = 2.0.94-5.3.el6_4.1 for package: libselinux-devel-2.0.94-5.3.el6_4.1.x86_64
--> Processing Dependency: libselinux = 2.0.94-5.3.el6_4.1 for package: libselinux-utils-2.0.94-5.3.el6_4.1.x86_64
---> Package libselinux.i686 0:2.0.94-5.8.el6 will be installed
---> Package libselinux.x86_64 0:2.0.94-5.8.el6 will be an update
---> Package libss.x86_64 0:1.41.12-14.el6_4.2 will be updated
---> Package libss.x86_64 0:1.41.12-21.el6 will be an update
---> Package nss-softokn-freebl.x86_64 0:3.12.9-11.el6 will be updated
---> Package nss-softokn-freebl.i686 0:3.14.3-18.el6_6 will be installed
---> Package nss-softokn-freebl.x86_64 0:3.14.3-18.el6_6 will be an update
--> Running transaction check
---> Package keyutils-libs-devel.x86_64 0:1.4-4.el6 will be updated
---> Package keyutils-libs-devel.x86_64 0:1.4-5.el6 will be an update
---> Package libselinux-devel.x86_64 0:2.0.94-5.3.el6_4.1 will be updated
---> Package libselinux-devel.x86_64 0:2.0.94-5.8.el6 will be an update
---> Package libselinux-utils.x86_64 0:2.0.94-5.3.el6_4.1 will be updated
---> Package libselinux-utils.x86_64 0:2.0.94-5.8.el6 will be an update
--> Finished Dependency Resolution
openssl-1.0.1e-30.el6_6.4.x86_64.rpm                                                                                                                                       | 1.5 MB     00:01
openssl-1.0.1e-30.el6_6.4.i686.rpm                                                                                                                                         | 1.5 MB     00:00
e2fsprogs-1.41.12-21.el6.x86_64.rpm                                                                                                                                        | 553 kB     00:00
glibc-devel-2.12-1.149.el6.x86_64.rpm                                                                                                                                      | 983 kB     00:01
nss-softokn-freebl-3.14.3-18.el6_6.i686.rpm                                                                                                                                | 154 kB     00:00
keyutils-libs-1.4-5.el6.i686.rpm                                                                                                                                           |  20 kB     00:00
e2fsprogs-libs-1.41.12-21.el6.x86_64.rpm                                                                                                                                   | 121 kB     00:00
zlib-1.2.3-29.el6.i686.rpm                                                                                                                                                 |  73 kB     00:00
libcom_err-1.41.12-21.el6.x86_64.rpm                                                                                                                                       |  37 kB     00:00
libselinux-utils-2.0.94-5.8.el6.x86_64.rpm                                                                                                                                 |  82 kB     00:00
libselinux-devel-2.0.94-5.8.el6.x86_64.rpm                                                                                                                                 | 137 kB     00:00
krb5-devel-1.10.3-33.el6.x86_64.rpm                                                                                                                                        | 498 kB     00:00
libselinux-2.0.94-5.8.el6.i686.rpm                                                                                                                                         | 109 kB     00:00
glibc-headers-2.12-1.149.el6.x86_64.rpm                                                                                                                                    | 611 kB     00:00
krb5-libs-1.10.3-33.el6.i686.rpm                                                                                                                                           | 773 kB     00:00
keyutils-libs-1.4-5.el6.x86_64.rpm                                                                                                                                         |  20 kB     00:00
keyutils-libs-devel-1.4-5.el6.x86_64.rpm                                                                                                                                   |  29 kB     00:00
libcom_err-devel-1.41.12-21.el6.x86_64.rpm                                                                                                                                 |  32 kB     00:00
glibc-2.12-1.149.el6.x86_64.rpm                                                                                                                                            | 3.8 MB     00:02
libselinux-2.0.94-5.8.el6.x86_64.rpm                                                                                                                                       | 108 kB     00:00
libcom_err-1.41.12-21.el6.i686.rpm                                                                                                                                         |  37 kB     00:00
nss-softokn-freebl-3.14.3-18.el6_6.x86_64.rpm                                                                                                                              | 164 kB     00:00
glibc-common-2.12-1.149.el6.x86_64.rpm                                                                                                                                     |  14 MB     00:13
glibc-2.12-1.149.el6.i686.rpm                                                                                                                                              | 4.3 MB     00:07
krb5-libs-1.10.3-33.el6.x86_64.rpm                                                                                                                                         | 765 kB     00:02
libss-1.41.12-21.el6.x86_64.rpm                                                                                                                                            |  41 kB     00:00